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Servoy Model Tool documentation
This document explains basic usage of the Servoy Model Tool Serclipse plugin.
A fair knowledge of Servoy and the Servoy IDE is required to be able to get the most of
this tool: This documentation does not cover the Servoy IDE but the added
functionalities the Servoy Model Tool offers to Servoy developers.
For installation of the Servoy Model Tool, please refer to the installation doc.
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Model Project
You will first need to have some solutions (with tables and relations) in your workspace if
you want to build schemas out if it.
Then you can either create a new "Servoy Model Project" or open the "Servoy Model"
perspective to get started.

Create a new Servoy Model project
Choose "File > New > Other...", then open the "Servoy Relation Model" node, and
choose the "Servoy Model Project" entry here:

Click next and input a name for your new project:
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If not opened already, you will be prompted to open the "Servoy Model" perspective,
click "Yes":
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Open the Servoy Model perspective
Alternatively, you can directly open the Servoy Model perspective, you will find it under
"Window > Open Perspective > Other...", just select it and choose "Open":
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Model Diagram
Create your first diagram
You can do that by choosing "File > New > Other...", opening the "Servoy Relation
Model" node, and choosing "Servoy Relation Model file",
or by right clicking on the "Models" node in the "Servoy Model View" or by clicking on the
icon with 3 little blue dots in the local toolbar of the "Servoy Model View":
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You will be presented with the New Model Diagram wizard's first page, where you will
need to choose a host project (a Servoy Model project), and a name for your Diagram):

(by default, the project will be the first project of type "Servoy Model Project" found in
your workspace, and the default name of the diagram file will be "Diagram" (the plugin
will automatically add an .smodel extension to it).
FYI: smodel files are just regular xml files, containing all the graphical information about
a diagram along with xml information about the Servoy objects they are related to, they
are self-contained and can be versioned in SVN along with your solutions.
You can click finish here if you want to create a new blank diagram, otherwise you can
click next, to choose which tables you want to automatically add:
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The wizard will list all servers found in the resources projects of your workspace,
provided that these contain .dbi files and are enabled, you can select all or only a few,
and you can select from multiple server sources as well.
You can stop there if you want or go to the next page to choose the solution(s) you want
to retrieve the relationships from:
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The wizard will list all the solutions and modules that contains relationships, you can
selec all or only a few, then you can stop there (and all the relations from these solutions
will be used), or go to the next page to choose the relations:
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Now click finish and the plugin will generate a diagram for you out of your selections.
You will see that, depending on the complexity of the solution and the number of
tables/relations and solutions you have selected, the result can be quite crowded:
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So probably the best option will be to create a blank diagram (just create a blank one
and click finish on the first wizard page, after having given it a name).
In any case, it's very easy to add tables and relations to a blank diagram and it is a bit
more manageable.
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Drag and Drop
Fortunately adding tables, relations and objects to a diagram is very easy; jus select
from the "Servoy Model Viewer" and drop on a diagram.
If 'Automatically add tables from relations' is checked in the preferences, you will see
that you can simply drag and drop relations and it will automatically add the tables if they
are not already in the diagram.
Dragging a column or a global (or scoped variable) onto another column will allow you to
create a new relation: you will be asked for a solution to host that relation (if there is
more than one solution available), and a check will be done on the automatic name to
verify that it doesn't exist already in the scope of your solution, allowing you to type a
new name if that's the case.
Most interactions in the diagram are intuitive and work as you will think they should, for
example, try moving objects around, right click on objects and you will see contextual
popup with various possible actions, pass the mouse over tables, columns and relations
and you will see tooltips, when an object is selected, it will also be selected in the Outline
view, and its extended properties will be shown in the properties view.
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Contextual palette
Tables, Globals/Scoped variables, Notes and Subgraphs have a little contextual palette
attached to them. When you put your mouse over one of these objects, you will see a
little palette of a maximum of 3 icons which are shortcuts to useful functions:


Delete: to delete an object (a dialog will ask for confirmation)



Update: if the Servoy model (.dbi or .rel) was changed when the diagram was
not opened, next time you open the diagram, you will see that you can update
the related element using this function (this is true only if the diagram itself has
the property "Keep synchronized" set to true)



Collapse: will toggle the collapse state of an object, leaving only the minimum
name entity (or a simple "g" for a global)
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Contextual menus
When you right click on an object in the diagram (or a group of objects), you will get
access to a contextual popup menu, which will list various functions:


Undo/Redo: each time you make a change to a diagram, and until you save it
each action will be recorded as an undoable action, so you will be able to get
back in your changes using 'undo', and forth in your changes using 'redo' - of
course the usual shortcuts apply (ctrl/cmd + Z and ctrl/cmd + Y)



Print: depending on what you have selected, you can print only the selected
objects or the whole diagram (ctrl/cmd + P works or course)



Copy/Paste: copy/paste works in between diagrams, but beware that you cannot
have more than one of the same object in one particular diagram (so you cannot
have 2 'addresses' tables for example), so it will not work if you try to copy and
paste in the same diagram



Update: does the same as the update icon in the contextual palette (shortcut
ctrl/cmd + F5 also works of course)



Delete: same thing as the delete icon in the contextual palette (shortcut DEL or
SUPPR key works as well)



Auto Resize: will force auto resize of objects (might not be needed anymore in
final version)



Toggle collapse: same as the collapse icon in the contextual palette



Toggle sort: works on tables only, will change the sort of fields from "Creation
order index" (the default in Servoy's table editor), to alphabetical



Move to subgraph… will allow you to move selected object to another diagram,
allowing you to choose one, or create a new one, and optionally automatically
add a subgraph to the current diagram



Force Model Refresh especially useful if your diagram has it’s ‘Keep
Synchronized’ flag set to false, and in some rare case where the model would be
desynchronized, forces the plugin to read the .dbi and .rel files again and check if
something changed.



Export diagram: will export an image of the currently selected object, or the
whole diagram, to various image formats (next version will also have SVG
export)

13 / 19

Servoy Model Tool documentation

Preferences
Each object you can use in a diagram can be individually styled using the properties
panel, or style changes can be applied to all opened diagrams and will be used for new
diagrams using the preferences. Open the Eclipse preferences and you will find a
"Servoy Model" node, with sub nodes for each object that you can use in diagrams.
The main "Servoy model" preferences node contains general preferences, style for the
diagram itself and a few useful properties:



Grid Unit: allows to define the size of the grid to be displayed



Background color: the color used by the diagram background



Foreground color: the color used by the lines of the grid
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Use straight bendpoints (this is a global preference, which cannot be
overridden by diagram), set whether to use straight lines or splines for relations,
also note that this option will not be applied immediately to opened diagrams.
You will need to close and reopen to see the effect of this option (a limitation I will
try to overcome in next versions).



Automatically add tables from relations: whether tables will be automatically
added when you drop relations from the "Servoy Model View" onto the diagram.
If false, a relation might not be added if the relevant source and destination
tables are not already in the diagram.



Keep synchronized: if you want your graphs to be automatically synched with
any changes made in the Servoy objects (.dbi and .rel files) of your workspace,
check that option. If you add a field in a table it will automatically appear in your
diagram in the table graphical object, if you delete it, it will be removed, etc.. if
you change relations, they will be re-routed automatically as well. If a global was
the source of the relation but is not anymore, it will be removed from the diagram
when the relation is re-routed unless this globals is also used by other relations.
You can override this option per diagram in the properties panel, so that you can
have diagrams with fixed versions, and others with always the latest changes.
(You can also force a refresh of the model at any time using the "Force model
refresh" context menu option in the diagram or on a specific object).



Show Columns PK



Show Columns Type



Show Columns Length



Show Columns Nullable

These 4 preferences define whether additional information will be visible in tables per
columns.
With these preferences unchecked, a table will look like this:
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With all these preferences checked, the same table will look like this:

Of course you can check/uncheck any of these properties individually.
And they can also be overridden per table object using the properties panel.
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Objects
A diagram can contain a certain number of objects:


Tables



Relations



Globals (or scoped variables in 6.1)



Groups



Subgraphs



Notes

Tables, relations and globals (or scoped variables)
Tables, relations and globals (or scoped variables), are directly coming from Servoy's
resources and solution projects, they are created from .dbi and .rel files respectively.
They are not directly editable since they are coming from the Servoy model itself. You
can double-click on a table, relation or global and it will take you directly to the table
editor, relation editor and the js files containing the global where you will be able to edit
as usual using Servoy's own editors.

Notes
You can also add Notes to a diagram. Notes are multi line text that you can edit to add
comments to the diagram.
You can put any number of notes in a diagram, and they can all be styled differently. By
default when you create a note, it will use the style set in the preferences "Note" node.
But you can tweak the style of each notes individually using the properties panel.
To create a Note, click in the palette on the "Note" object:
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Then click on the diagram (the cursor will change into a little +, showing you that you will
add an object), this will put you in "Direct edit" node where you can type the note text
directly inside the object.

Groups
You can also create Groups, which is a convenient way to group some entities that are
part of the same logical functionality in your solution.
Groups will always display underneath the other objects. You can drag and drop tables,
relations etc. to add them to a group and you can resize it to make it fit the underlying
objects. Groups are convenient to show that some objects are directly related and do
certain things, but they are also an easy way to move many shapes in one go.
To create a group, select the Group object from the palette:

Then drag onto the diagram to define a group zone. After you've dragged you will be put
into "Direct Edit" mode where you will be able to add a title to you group, by typing it
directly in the new group shape.
Groups will use the preferences set at the application level when you create them but of
course you can always override these by using the properties panel.

Subgraphs
Finally one useful object you can have in a diagram is a Subgraph. Think of subgraphs
as links to other diagrams. When you double click on a subgraph, it will open the related
diagram in the diagram graphical editor.
When you add a subgraph from the Palette tool, it will ask for the name of a diagram:
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If that diagram already exist in the Model project, it will be used and linked, otherwise a
new diagram will be created with the same name as the diagram. You can also drag and
drop another diagram from the "Servoy Model View" onto the diagram surface and it will
create a new Subgraph.
Subgraph are useful to navigate in a big solution where many subgraphs are necessary
to organize the information.
One use of subgraph is also as a drop target for other objects, you can use subgraphs to
move a table from one graph to another, you can move tables, relations, globals, notes
and subgraphs from one subgraph to another simply by dragging them and dropping
them on a subgraph object.

19 / 19

